Logo Search packages:      
Sourcecode: fckeditor version File versions  Download package

fckeditor.php

<?php
/*
 * FCKeditor - The text editor for Internet - http://www.fckeditor.net
 * Copyright (C) 2003-2007 Frederico Caldeira Knabben
 *
 * == BEGIN LICENSE ==
 *
 * Licensed under the terms of any of the following licenses at your
 * choice:
 *
 *  - GNU General Public License Version 2 or later (the "GPL")
 *    http://www.gnu.org/licenses/gpl.html
 *
 *  - GNU Lesser General Public License Version 2.1 or later (the "LGPL")
 *    http://www.gnu.org/licenses/lgpl.html
 *
 *  - Mozilla Public License Version 1.1 or later (the "MPL")
 *    http://www.mozilla.org/MPL/MPL-1.1.html
 *
 * == END LICENSE ==
 *
 * This is the integration file for PHP (All versions).
 *
 * It loads the correct integration file based on the PHP version (avoiding
 * strict error messages with PHP 5).
 */

function FCKeditor_IsCompatibleBrowser()
{
      global $HTTP_USER_AGENT ;

      if ( !isset( $_SERVER ) ) {
            global $HTTP_SERVER_VARS ;
          $_SERVER = $HTTP_SERVER_VARS ;
      }
            
      if ( isset( $HTTP_USER_AGENT ) )
            $sAgent = $HTTP_USER_AGENT ;
      else
            $sAgent = $_SERVER['HTTP_USER_AGENT'] ;

      if ( strpos($sAgent, 'MSIE') !== false && strpos($sAgent, 'mac') === false && strpos($sAgent, 'Opera') === false )
      {
            $iVersion = (float)substr($sAgent, strpos($sAgent, 'MSIE') + 5, 3) ;
            return ($iVersion >= 5.5) ;
      }
      else if ( strpos($sAgent, 'Gecko/') !== false )
      {
            $iVersion = (int)substr($sAgent, strpos($sAgent, 'Gecko/') + 6, 8) ;
            return ($iVersion >= 20030210) ;
      }
      else if ( strpos($sAgent, 'Opera/') !== false )
      {
            $fVersion = (float)substr($sAgent, strpos($sAgent, 'Opera/') + 6, 4) ;
            return ($fVersion >= 9.5) ;
      }
      else if ( preg_match( "|AppleWebKit/(\d+)|i", $sAgent, $matches ) )
      {
            $iVersion = $matches[1] ;
            return ( $matches[1] >= 522 ) ;
      }
      else
            return false ;    
}

if ( !function_exists('version_compare') || version_compare( phpversion(), '5', '<' ) )
      include_once( 'fckeditor_php4.php' ) ;
else
      include_once( 'fckeditor_php5.php' ) ;

?>

Generated by  Doxygen 1.6.0   Back to index